[精讚] [會員登入]
240

[phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本

使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

此文完整連結 http://n.sfs.tw/10647

複製連結 [phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本@新精讚
(文章歡迎轉載,務必尊重版權註明連結來源)
2017-01-22 11:50:33 最後編修
2017-01-22 11:39:02 By 張○○
 

使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

這是由於phpmyadmin4以後要求的mysql伺服器端版本至少要5.5.0,請注意不是用戶端的版本,我在這裡卡了不少時間,低於此版本就會出現這個錯誤。

事實上我發現就算是低於這個版本的mysql server例如5.1,還是可以使用phpmyadminn4運作順利,至少大部分的操作沒遇到問題。

除了升級伺服器端的版本外,有些狀況不能升,所以還有一個駝鳥型的解決方法:

vi phpmyadmin/libraries/common.inc.php

查找
if (PMA_MySQL_INT_VERSION < 50500) {

修改為
if (PMA_MySQL_INT_VERSION < 50100) {

即可

你可能感興趣的文章

[PHP] 類別的繼承及建構子和解構子 PHP 類別的繼承及建構子和解構子

[PHP] 隨機產生一個顏色字串 讓PHP 隨機產生一個顏色字串

[CodeIgniter 3] 資料庫的使用方法整理1/2 --Select的使用 [CodeIgniter 3] 資料庫的使用方法整理:Select的使用

[PHP7] 利用Memcached 儲存 Session Memcached+ PHP7,利用Memcached 儲存 Session。

[PHP] 命名空間 namespace及 use PHP >=5.3 開始支援命名空間:namespace

[PHP] 檢查IP是否在某個網段內 mtachcidr 要檢查IP是否在某個網段內,要寫幾行?10行?5行? 不用,只要2行。以下是我寫的 code /** * matchCI

[CodeIgniter 3] 修改或插入資料時遇到函數的處理 CI3 中要新增或修改的資料中如果有 now()這類的函數,要怎麼處理?

[PHP] 處理mail 函式的標題中文字亂碼 PHP的mail函式若標題有中文字得先處理過,否則收信者會看到亂碼

[phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本 使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

使用strcmp來判斷日期是否介於某日期之間 要比較現在日期是否在兩個日期之間,使用字串比對的方法

我有話要說


限制:留言最高字數1000字,超過部分會被截掉。請注意:留言不可帶有網址,會被濾掉。 限制:未登入訪客,每則留言間隔需超過10分鐘,每日最多5則留言。

訪客留言

[無留言]

隨機好文

談借錢 人借錢時手心向上頭向下,人還錢時手心向下頭向上

NETCRAFT發現你的網站及作業系統 NETCRAFT可以發現你的網站及作業系統

[CodeIgniter 3] 資料庫的使用方法整理1/2 --Select的使用 [CodeIgniter 3] 資料庫的使用方法整理:Select的使用

[Wildfly10] 發佈war檔 deploy war file onto wildfly10

[MAC] 安裝APACHE+PHP OS Darwin OpenIDMac1deAir 15.6.0 Darwin Kernel Version 15.6.