[精讚] [會員登入]
1332

centos7 apache ssl.conf設定狀況

“
在apache更新或重啟後可能遇到ssl.conf衝突問題
„

分享此文連結 //n.sfs.tw/12115

分享連結 centos7 apache ssl.conf設定狀況@外行中的外行
(文章歡迎轉載,務必尊重版權註明連結來源)
2019-10-17 16:02:30 最後編修
2018-01-11 10:21:56 By jung
 

在使用apache2做reverse proxy並設定ssl.conf的時候

參考精讚大神以預設的wildfly-le-ssl.conf去修改沒有問題

不過有時cnetos7 在yum套件更新後

系統自動重啟時,apache又會重新產生一個預設的ssl.conf設定檔

導致與原本wildfly-le-ssl.conf的設定衝突

因為兩個檔案都會listen 443

如果只把listen 443註解掉

ssl模組去找key&pem時就會先找到apache預設產生的加密檔

就造成https網頁失效

為了避免這個問題

精讚大神建議,直接將/etc/httpd/conf.d/wildfly-le-ssl.conf檔

在設定ssl key&pem檔案位置完成後

手動將wildfly-le-ssl.conf改名為ssl.conf

再重啟apache

讓apache查到ssl.conf就不會產生新檔了

mv wildfly-le-ssl.conf ssl.conf
systemctl restart httpd

以上紀錄

END

你可能感興趣的文章

logrotate執行權限問題 logrotate will failed to execute if selinux policy not setup correctly

測試及處理slow http attack on Apache 2.4.6 at CentOS-7 avoiding and testing slow http attack

IIS10設定url rewrite to https if you setup url rewrite function in IIS10, might cause api callback failed

如何在ubuntu 18.04上設定一開機就啟動virtualbox某個vm a way to setup ubuntu18.04 for start vm on boot

centos7 apache ssl.conf設定狀況 在apache更新或重啟後可能遇到ssl.conf衝突問題

setup jira using ssl on apache reverse proxy 設定jira使用https連線

隨機好文

縣市IDP更換SSL憑證及修改servername+wildfly等設定 縣市IDP更換SSL

新增縣市端回傳使用者資料功能 新增縣市端回傳使用者資料功能

intellij IDEA git設定說明 whenever using git push fuction in the intellij IDEA

系統不正常關機導致mongodb啟動失敗 重新安裝mongodb使用mongorestore

openssl package update issue caused by cve-2022-2068 centos7 is at maintenance support phase2, only critical impact security issues will be patched