[精讚] [會員登入]
1721

IIS10設定url rewrite to https

“
if you setup url rewrite function in IIS10, might cause api callback failed
„

分享此文連結 //n.sfs.tw/13164

分享連結 IIS10設定url rewrite to https@外行中的外行
(文章歡迎轉載,務必尊重版權註明連結來源)
2019-10-24 09:49:24 最後編修
2019-03-13 14:27:13 By jung
 

為了讓更改密碼的程式能放到外網執行,於是開始研究如何在IIS上新增let's encrypt免費憑證

可參考下列網站

http://my01info.blogspot.com/2017/09/iislets-encrypt-ssl.html

然後設完後很開心想說可以如linux一樣設個url rewrite把所有http的連線都轉到https

結果卻不是這樣,一旦設了url rewrite會把api回傳的資料都丟到https結果變成無法更改密碼了~哭哭

所以只能靠防火牆擋掉到iis 80 port的連線~

相關設定可以參考這篇

https://www.namecheap.com/support/knowledgebase/article.aspx/9953/38/iis-redirect-http-to-https

還有IIS設定網址繫結的意思也跟dns紀錄的意思不同,我設了結果變成用domain可以連線,用ip卻不行了?!

目前還是暫時沒設

看來還要請教高人,基本上只要dns 正反解設定正確就能用網址連線了

 

 

END

你可能感興趣的文章

IIS10設定url rewrite to https if you setup url rewrite function in IIS10, might cause api callback failed

bitbucket repository control application setup 安裝完bitbucket服務後,須設定bitbucket.properties

nginx+ssl+certbot安裝設定雜記 using certbot on nginx to setup https connection

JIRA using gmail as smtp outgoing mail sender 如何設定jira使用gmail信箱送信

在家設定openvpn server on pfsense 在家設定openvpn server on pfsense

how to add physical disks into HP smart array through esxi interface 如何在磁碟陣列卡上加入新的硬碟-未完待續

隨機好文

在virtualbox如何壓縮vdi檔 using commands to reduce virtualbox's vdi file space

如何在ubuntu 18.04上設定一開機就啟動virtualbox某個vm a way to setup ubuntu18.04 for start vm on boot

更新程式環境到wildfly18+openjdk11-phase4: 認證程式更新 認證程式更新

solution for selinux issue while installing zabbix agent on centos7 install zabbix agent as service will raise selinux issue on some centos 7.3.1611

openssl package update issue caused by cve-2022-2068 centos7 is at maintenance support phase2, only critical impact security issues will be patched